Spout Error - Touchdesigner to Resolume - Cannot create DirectX/GL interop

I know this question has been asked a bunch, however I am finding myself stuck with no errors in the logs that I can see, all connections established correctly and everything running on the same graphics card (NVIDIA RTX 3080).

Everything has been running fine for the last 3 days, with visuals sending out of Touch Designer into Resolume Arena v 7.13 via Spout v 2.007… and suddenly today, after everything running for an hour this morning with no problems, I started to get this error “Cannot create DirectX/GL interop”… Resolume crashed and now every time I try to establish the link between Touch and Resolume the error appears again.

I’m pretty stumped. I check all the things previously suggested… I’ll paste my logs and info here, maybe someone can spot something I’ve missed?

Spout System Diagnostics says:
DirectX 9c Installed
DirectX 11 device available
Primary adapter: NVIDIA Corporation
NVIDIA GeForce RTX 3080 Laptop GPU (Display): Microsoft Basic Render Driver (Secondary)
Laptop System detected
NV_DX_interop extensions available
OpenGL/D11 texture sharing succeeded
Compatible for OpenGL texture sharing

The logs after a crash say the following:

Spout log file

2022-11-23 12:05:38
[notice] SpoutSettings : SpoutPanel already registered
[notice] spoutGL::OpenDirectX
[notice] spoutDirectX::OpenDirectX11
[notice] spoutDirectX::CreateDX11device - pAdapter (0x0000000)
[notice] Device (0x441E8D10) - Context (0x441EA048)
[notice] spoutGL::CleanupDX11()
[notice] spoutDirectX::CloseDirectX11(0x441E8D10)
[notice] spoutGL::LoadGLextensions - all extensions available
[notice] spoutDirectX::OpenDirectX11
[notice] spoutDirectX::CreateDX11device - pAdapter (0x0000000)
[notice] Device (0x43F019F0) - Context (0x419D0DC8)
[notice] spoutGL::GLDXready - testing for GL/DX interop compatibility
[notice] GL/DX interop extensions available
[notice] spoutDirectX::CreateSharedDX11Texture
[notice] pDevice = 0x43F019F0, width = 256, height = 256, format = 87
[notice] pTexture = 0x43E665B0 : dxShareHandle = 0x0003242
[notice] Linking test - OpenGL texture (0x0000001) DX11 texture (0x43E665B0)
[notice] spoutGL::CleanupInterop
[notice] spoutDirectX::ReleaseDX11Texture (0x43E665B0)
[notice] Test OpenGL and DX11 textures created and linked OK
[notice] spoutGL::CleanupDX11()
[notice] spoutDirectX::CloseDirectX11(0x43F019F0)
[warning] spoutDirectX::ReleaseDX11Device - refcount = 1

When I open my NVIDIA GPU activity panel, under Applications running on this GPU, I see

  • touchdesigner.exe
  • resolume arena 7.13

… I dont see spout there, but I also don’t see any information in the SpoutSettings about how to select the graphics card… I un-ticked the Auto Share box next to “OpenGL graphics compatibility” because I read in a previous post about this same error that it might help, so far for me it doesn’t change anything.

My spout settings say that my NVIDIA driver version is 526.98, optimus global processor is set to high performance, and I turned Threaded optimization off… still I get the error.

My computer specs:

XMG NEO 15 (Early 2021)
NVIDIA GeForce RTX 3080 | 16 GB GDDR6
AMD Ryzen 9 5900HX
8 GB DDR4-3200 Crucial
Windows 11

any help or clues are supper appreciated!

The SpoutSettings diagnostics don’t show any incompatibility generally. Leave “Auto share” checked on.

I see Windows 11 in your specs. At this time I have not been able to work with Windows 11 because the hardware requirements do not allow a simple upgrade. But I don’t think this is the problem.

You have already checked that both Resolume and Touch Designer are using the same GPU as far as the NVIDIA driver is concerned. But there is one more thing to check and that is Windows “Performance Preference” which can over-ride the driver settings.

Go into Settings > System > Display > Graphics settings and you should see “Graphics Performance Settings”. This is for Windows 10 but you should find the same or similar for Windows 11.

Here you can select individual applications, Arena and Touch Designer. Set each for Graphics preference “High performance” and see whether that resolves it.

Thanks for these suggestions! I tried adjusting the settings like you said, but the crash is still occuring… In the meantime I tried using NDI instead and it seems to just work. Althought I get the impressions there’s a lag now, where with Spout there was none… I’ll keep trying to tweek things tho. If I get it working I’ll post my findings here.

I hope you are able to track this down.

In your case, the strange thing is that it was working for an hour or so and happened without any input on your part. Is it possible that either Resolume or TouchDesgner updated itself on start? That could have reset the NVIDIA profile settings?

The Windows Graphics Settings do take priority over driver settings as I mentioned earlier and I gave a link to NVIDIA advice in this post.

I expect that you have already made sure that both programs are not registered with Windows Graphics Settings and that both have a profile established with the NVIDIA Contral panel “Program Settings” and both “OpenGL rendering GPU” and “Power management mode” specify the NVIDIA GPU.

The only other thing that comes to mind is to remove the NVIDIA profiles for each program from the NVIDIA control panel, and set Windows Graphics Settings for both to high performance. Resolume will detect that the profile is missing so don’t update that for the duration of the test. For this reason, it probably isn’t a good permanent solution but the test might be worth the time.

Meanwhile NDI will work quite well on the local machine but it uses the CPU and compression methods that inevitably take some time.

mismo problema en windows 11 RTX 3080

Hello Eduardo

This is an old error message. What version of Resolume are you using?

Use the latest Spout version.
Run “SpoutSender.exe” and then “SpoutReceiver.exe”.
Does the receiver show the sender output?

From the receiver menu, select “Help Diagnostics”, click “Copy” and paste the results here.

Solved problema. Mala configuración inicial para mi. He activado High performance in optimua global procesor y problema resuelto, Muchas Gracias

Enviado desde Correo para Windows

OK Eduardo, that’s good to hear.