Spout

Spout from resolume - fail

Hello dear all.
I am triyng to receive |Resolume´s output into Spout receiver.
It is not working.
If I try with Spout Sender, it works fine. But with resolume… dont
The weird thing is that Spout recognizes both resolume outputs in ´select sender´ menu: the compostion and also the advanced output screen.

can you help me with it?

tks

Hi @Felipejulian,

That’s strange if you can receive from the Spout demo sender but not Resolume.

I suggest to start Resolume, activate Spout output and then start the Spout demo receiver. Select Help > Diagnostics, click “Copy” and paste the result here. That might tell us something about what is going on.

\Hello

Thank you for your attention. I Really need to put this to work

Here the log:

DirectX 9c installed

DirectX 9 device available

DirectX 11 device available

Intel® UHD Graphics 630 (Display)

Microsoft Basic Render Driver (Secondary)

Current adapter : Intel

Laptop system detected

NV_DX_interop extensions available

OpenGL/DX11 texture sharing suceeded

Compatibility - Texture (DirectX 11)

Enviado do Email para Windows 10

As it says in the log, this tells me that you have a laptop with Intel UHD graphics 630 and that OpenGL/ DX11 texture sharing succeeded. The Spout Demo progams should say “Spout DX11 Sender” and “Spout DX11 Receiver”.

Is this a laptop with NVIDIA/Intel “Optimus” graphics?

First of all… thank you very much for your help.

I will type you my setup in this machine:

with Intel UHD graphics 630

8239 MB

144hz

NVIDIA GEFORCE RTX2060
I find some references to Optimus but not sure what it is about. Sorry.

Again…

Thank you for your fast response… really a mass here with this job and its deadline!

6D15436B432C47C7B3AE4DDD866A8577.png

If you have both Intel UHD graphics 630 and NVIDIA GEFORCE RTX2060 graphics in the same machine it has “Optimus” switching graphics. Intel is used to save power when high performance is not needed. Geforce is used for high speed graphics applications and is required for Spout texture transfer.

First open SpoutSettings to make sure it is set up correctly :

DirectX 9 - Off
Share mode - “Texture”
NVIDIA Optimus global processor - “High performance”
Other settings are not important.

Next open the NVIDIA control panel to confirm that Optimus “High performance” is selected.

RH click on the desktop.
NVIDIA control panel.
Manage 3D Settings at left.
Global Settings tab at right.
Preferred processor at top
“High performance” should be shown. If not, select it from the list.

Now try Resolume -> Spout demo receiver

If that does not work, we might not have time to test other things. You could try using “NDI” as a CPU-based alternative if the receiving application supports NDI. If you can keep the resolution down, performance may be suitable for your job.

In Resolume, select Output > Network streaming (NDI). In your receiving application will need to select NDI input.

To test NDI you can download the Tools (https://ndi.tv/tools/).

Let me know what application you want to share Spout textures with so that I can understand more about what you want to do.

Thnak you very much for your help!

It Works! Great!

Now I will try a way to record this 4k output.

I tryed |LightJams but it cannot handle framerate abpve 15fps.
Researching here!

Thank You agani!

Felipe

Enviado do Email para Windows 10

OK that’s good.
You could try OBS Studio for recording. There are Spout and NDI plugins for that.