Problem with Unity and Resolume

I used to use Spout with a Unity build and Resolume 7.2.1 and i worked. I had to reinstall the computer and now I have problem. The spout texture can be seen in Spout Receiver but Resolume displays only black. I’d say it works every 2 boots.

I tried many Spout versions, assuming we only need to run settings program to make the change between versions? I tried many parameters without luck.

It seems to work on the same computer but on a different Windows boot.

I’m using a Unity build made in Unity 2017, Resolume 7.2.1, Spout 2007-012, Windows 10, RTX 4090.

Ok, I unchecked Auto share and Frame count. It seems stable again.

Also had to modify registry with this entry:

Computer\HKEY_CURRENT_USER\Software\Leading Edge\Spout\DX9 = 0

SpoutSettings should remove or reset old keys, but I will check.

The registry entry dx9 gets reseted to 1 by itself and I need to change it. I don’t know why.

I checked with SpoutSettings from the latest release 2007-012 and if I add a DX9 entry, it is removed after click on OK and exit.

You should be able to confirm this by running SpoutSettings while examining the registry. Use RegEdit “View > Refresh” after closing SpoutSettings.

Another program must be setting the DX9 key. I checked the latest version (7.19) of Resolume Arena and it does not set the key. Can you check Unity. What are you using within Unity?

Thanks for checking.

I did not mention it because I though the problem was between Unity and Resolume but I’m also using VVVV 50 beta35.8 (built 2017) and Max 8. I think it’s Max doing the problem. Every time I launch my patch using Spout, the registry changes.

In Unity I’m using the plugin Klak.

I found the cause in the Max external source code. Max works correctly but Resolume Spout output switches to DirectX9 thereafter, slows to 4-5 fps and consumes memory. If Spout output is checked off, Resolume is OK and receives from any spout sender, so Unity will be received without problem as long as Resolume Spout output is checked off. Opening SpoutSettings removes the key and Resolume output works normally again. VVVV is DirectX9 but does not change the registry.

Edit -
The developers update might take a while, meanwhile here’s a batch file that will remove the DX9 entry.

I never checked Resolume Spout output.
The batch file doesn’t seem to remove the DX9 key. Is there something you suggest I must do with it?
Max keeps changing the DX9 key each time I use Spout with it.

Unity looks to work fine when DX9=0 when it starts and keeps to work fine even if the key is changed after to 0. So, the boot order of the softwares is important; but it’s not a practical solution.

Sorry, my mistake. I was using an updated version that removes the key.
I aim for a new Spout release in the new year. Meanwhile here is a pre-release copy.

I will look into that batch file. It might require admin privileges. Console output is suppressed, but can be put back in by removing -
/f nul 2> nul
This might show errors if you open a command console first.

I have contacted the developers of the Max external and Resolume, so hopefully this will be resolved. The modification required for the Max external is minor as you can see, and that would fix it.

The developer of the Max external has responded and said that he will look into it.


For the batch command, it asks to confirm the operations, that’s why it was not doing anything without the command window.
But as soon as I run Max the key reappears again. Do you suggest to run the batch file automatically with Max after the patch started to run? In that case I would need to remove the confirmation to do it automatically.

The spout settings doesn’t seem to remove the key. But anyway that doesn’t solve the problem. In a way or another, I have to remove the key using Registry or something else.

Thank you for asking the Max external developper. Is it possible to be warned when the new version is up?

I think I found the problem with SpoutSettings. Try this version. The zip file includes the batch files.

I am not sure why you see the confirm prompt. It has an “/f” switch that should force deletion without a prompt. A quick search reveals that other people have had the same problem.

Max will set the DX9 key value to 1 as soon as the external starts. I am not sure how you would run the batch file automatically within the patch, but it would need to happen after the external loads.

It should work out if you open the Unity plugin and Resolume before opening Max and run the batch file or SpoutSettings after closing Max.

I expect that the Max external will be available in the Package manager when the revised version has been published. You could keep an eye on the Cycling 74 forum for announcements.

Ok the new batch file and settings work.
I did not success to execute the batch file from Max.
I will wait for an update of the Max external.

The developer of the Max external has advised -

this change has been committed and the externals updated and pushed to the Package Manager as Spout package version 2.0.75

Thanks for the heads up.