Spout problem with VidJam

I am using a music visualizer called VidJam which natively supports Spout.

However, I just noticed that Spout no longer works with my DJ software or OBS.

Additionally I tested another Spout sender called NestDrop and it performed normally with both the DJ software and OBS.

This suggests to me that Vidjam is having a problem with Spout.

I wanted to ask here before i send in a ticket to the VidJam software folks.


Thanks in advance.

Happy Holidays.

Hi @UltraLiver - yes indeed, the new year is almost upon us.

I downloaded and installed VidJam and find that it works perfectly with OBS, so I think there must be another problem somewhere. The first test would be to run the Spout demo receiver to find out whether that receives from VidJam. Presumably the Spout demo sender is received by OBS and your DJ software. Hopefully you can narrow it down.

Then there’s the perennial problem of laptops with multiple graphics adapters to provide power saving or performance options. We have also been caught more recently with Windows Graphics preferences.

In the first case, make sure the driver is set up for both sender and receiver applications to use the same graphics adapter.

In the second case, each application has to have the same Windows graphics preference if one or both are registered. This setting over-rides the driver so if one is registered and the other is not there can be a problem.

I will be publishing a new Spout release soon, hopefully in the next few days, that includes the Windows preferences in SpoutSettings. But at the moment you can manage them directly.

Settings > System > Display > Graphics settings

These are a few things to try but I don’t think that VidJam is the immediate problem as far as I can tell.

Thanks for your detailed response.

I continued to investigate Vidjam and it’s settings, and guess what?

I found a tiny button that says “blackout” via a tooltip. Apparently that turns off Spout and possibly other interactions. I deactivated the blackout setting and Spout was restored.

Happy Holidays.

Close this ticket but make it searchable on the web so that others can learn from my self-induced problem.

Yes I found it. It fades the output to black rather than disable it. I can see this in the settings. Anyway problem solved. This topic will remain in the forum for future reference.